Terminus 3.0 Feedback

The good:

  1. Terminus Hub is awesome! It’s obvious you folks spent a LOT of effort working on it and it shows. It was very exciting to be able to just download a dataset with the push of a button. Bravo!
  2. I love the improved and expanded documentation section. Will spend a lot of time getting up to speed there!

The frustrating:

  1. The Windows installer kept not launching. I tried to launch it, had to get past the Windows Defender screen, nothing. Run as administrator, nothing. Then after I tried one last time after giving up on getting bootstrap to work, it finally worked for some reason.

  2. When bootstrapping, I couldn’t access Terminus Hub from the browser at localhost:6363 with the below error:

  3. It’s very confusing that the desktop client won’t start Terminus Server by itself and needs you to bootstrap the server anyway.

  4. I’m frustrated by the decision to remove the Docker Compose file - submitted a GitHub issue about it.

Don’t let the frustrations take away from the good though. I got 3.0 to work, and it works beautifully so far, and is full of wonderful and extremely useful new features. Great job Terminus team!

Aram

Thanks a lot for your feedback!

About the localhost problem, this has security reasons. Accessing the console with https://127.0.0.1:6363 will work! The reason for this is that there is a risk of localhost resolving to something different than 127.0.0.1. What if people removed it from their /etc/hosts and it resolves to something else? With 127.0.0.1 we have the guarantee that it is the local machine.

1 Like

Hey Aram!

When you are using bootstrap ./terminusdb-container run shows you the correct url for the console.

$ ./terminusdb-container run

terminusdb-server container started https://127.0.0.1:6363/

Also, if you have python installed, you can use ./terminusdb-container console which will open your default browser to the correct url

Can you let me know what you mean by “the desktop client won’t start Terminus Server by itself and needs you to bootstrap the server anyway.”

If you are using TerminusDB Desktop, you don’t need to have bootstrap, the server is installed with the Desktop installer. You would only need this if you where running the Desktop development server via npm rather than the released version. Let me know if I can help with this.

The docker-compose file is being moved from bootstrap, since bootstrap does not use docker compose, to the main server repo (terminusdb-server) since docker compose is a popular way for people to run Docker containers as a more DIY alternative to bootstrap.

1 Like

Hi @dmytri,

I just tried again with the same result. Basically the desktop client launches very quickly, but then just says “Connection Failure”. Starting terminusdb manually via bootstrap allows the desktop client to make a connection.

OS: Windows 10 with Docker Desktop installed

Also, I tried bootstrapping with the new docker-compose file just now. It works great but I still can’t connect to Hub, even from 127.0.0.1. Is it because HTTPS is disabled?

image

Yeah, hub will on allow you to login to https://127.0.0.1, https is required.

Can you try to run desktop without having bootstrap running? If the Database is running, Desktop will not be able to use the port 6363.

The compose file is just an example, and not recommended in most cases, it’s there for people who want to create there own deployment with docker compose, neither bootstrap nor desktop uses it.

Regarding the compose file: Got it, no worries.

I’ve already tried to start Terminus Desktop twice after a fresh restart. Same result…

Aram

1 Like

Are you on our Discord server? Would love to have you share your screen and show me, because I’m clear on what is happening.