Terminusdb/terminusdb-server docker image behind https proxy

I am having trouble deploying terminusdb/terminusdb-server:dev to a k8s cluster. it seems to start up fine. The logs:

SERVER_PORT 6363

% Started server at http://localhost:6363/

% TerminusDB server started at Tuesday, Apr 12, 17:20:38 UTC (utime 1649784038.8244197) args [serve,help(false),interactive(false),memory(_12258)]

% Welcome to TerminusDB's terminusdb-server, version 10.0.23!

% You can view your server in a browser at 'http://localhost:6363'

I have TERMINUSDB_PUBLIC_URL set to https://<my-domain> , TERMINUSDB_SERVER_PORT set to 6363 , and TERMINUSDB_ADMIN_PASS passed in as a secret. I have a load balancer with a ssl cert for the public url redirecting to the terminus container port 6363.

I suspect that the logs indicating localhost as the host is the issue, like I want 0.0.0.0 probably. However, setting both TERMINUSDB_SERVER_HOST and TERMINUSDB_HOST to 0.0.0.0 does not make a difference.

Iā€™d appreciate any advice.

I am delighted to report that I am an idiot and forgot to add the appropriate CNAME record for my SSL cert domain. I am now up and running. FYI TERMINUSDB_PUBLIC_URL is not needed.

So, it works for me setting just TERMINUSDB_ADMIN_PASS and TERMINUSDB_SERVER_PORT.

1 Like